Librería necesaria para Linux modernos como DEBIAN 12 que soporta múltiples programadores.

Entorno de desarrollo para Spartan 6 e inferiores (también soporta algunas Artix 7)
Avatar de Usuario
Subcritical
Spartan 3
Mensajes: 231
Registrado: 24 Ago 2018, 14:52

Librería necesaria para Linux modernos como DEBIAN 12 que soporta múltiples programadores.

Mensaje por Subcritical » 23 Jun 2023, 13:02

Modelos de cables soportados:
XILINX Platform Cable USB II
XILINX Platform Cable USB DLC9, DLC9LP and DLC9G
Integrated Platform Cable USB on Spartan 3E starter kit
Integrated Platform Cable USB on Spartan 3A starter kit
Integrated Platform Cable USB on XUP-V2Pro
XILINX Parallel Cable IV (in Parallel Cable III compatibility mode)
FCPU-X platform cable (XILINX Platform Cable USB clone)
Enterpoint Prog2 Parallel Cable III clone
Trenz TE0149-01 Parallel Cable III clone
Digilent JTAG3 Parallel Cable III clone
Amontec JTAGkey-Tiny (experimental)

Para poder compilarla hay que tener las sisguitentes dependencias de paquetes instaladas

Código: Seleccionar todo

apt-get install libusb-dev
Descargar el fichero:
usb-driver-HEAD.tar.gz
http://git.zerfleddert.de/cgi-bin/gitwe ... EAD;sf=tgz
Repositorio GIT:
http://git.zerfleddert.de/cgi-bin/gitwe ... ver?a=tree

Clonar el repositorio:

Código: Seleccionar todo

git clone git://git.zerfleddert.de/usb-driver

Ejecuto el script que llevan los fuentes.

Código: Seleccionar todo

sh /home/jaime/fuentes/usb-driver/setup_pcusb
Y luego cambio la linea del arrancador de ise por la nueva librería más moderna:

Código: Seleccionar todo

#export LD_PRELOAD=/opt/Xilinx/14.7/usb-driver/libusb-driver.so
export LD_PRELOAD=/fuentes/usb-driver/libusb-driver.so
Funcionamiento de todo el ISE en DEBIAN 12:
shot-2023-06-23_12-33-21.jpg
shot-2023-06-23_12-33-21.jpg (439.49 KiB) Visto 3285 veces

Responder

Volver a “ISE”